error installingNuGetPackages

Sep 29, 2011 at 9:34 PM


Installation going fabulous until I tried to install the NuGet Packages.

See error message below. What am I missing?


PM> .\InstallRequiredNuGetPackages.ps1



The term '.\InstallRequiredNuGetPackages.ps1' is not recognized as the name of

a cmdlet, function, script file, or operable program. Check the spelling of the

name, or if a path was included, verify that the path is correct and try again


At line:1 char:35

+ .\InstallRequiredNuGetPackages.ps1 <<<<

+ CategoryInfo : ObjectNotFound: (.\InstallRequiredNuGetPackages.

ps1:String) [], CommandNotFoundException

+ FullyQualifiedErrorId : CommandNotFoundException


Sep 29, 2011 at 9:53 PM

I have seen this when I forgot to open up the MileageStats.sln before trying to run the script from the Package Manager console.



Sep 29, 2011 at 10:14 PM

Thanks Michael.

I did run it from within the MileageStats solution. 

Any other suggestions?


Sep 29, 2011 at 11:26 PM

If you do a call to Get-Location (or PWD), does it return the folder that the solution file is in?

If not, you may need to Set-Location (or CD) to the folder the solution resides in.  That folder should contain the InstallRequiredNuGetPackages.ps1 file.

If you are in the correct folder, and a call to Get-ChildItem (or DIR) shows that the file InstallRequiredNugetPackages.ps1 exists in the folder, let me know and we can try to figure out what is going on.


Sep 30, 2011 at 3:15 PM

Thanks Michael

that worked!