Silk, MVC 4, and the .Net 4.5 Framework

May 30, 2012 at 6:57 PM

Is it true that this project requires the .Net 4.5 framework, and MVC 4 is not compatible with it?

May 31, 2012 at 2:30 PM
Edited May 31, 2012 at 2:30 PM

Hi,

Yes, It doesn't work with MVC4. You'd better install MVC3 first then following with MVC4. Update the code by yourself to support MVC4

Best,

Weera

Developer
May 31, 2012 at 3:00 PM

Hi,

Based on the understanding the purpose of this guidance is to show you how to plan, design, and build a rich, interactive web application using different web technologies like ASP.NET MVC 3. To illustrate the concepts explained the guidance provides a sample application called Mileage Stats Reference Implementation, which take advantage of this technologies. As you can find this sample is an MVC 3 Web application, and it uses .NET Framework 4 as the Target Framework.

You could find more information about this, and the System Requirements of the Mileage Stats RI in the introductory chapter of the Silk documentation:

Regarding MVC4 as far as I know, you could also find most of the concepts explained in the guidance useful, as this is in general the same rendering engine as MVC3.

Also you could find more information about this in the following link:

Regards,

Agustin Adami
http://blogs.southworks.net/aadami