I have a problem at RepositoryInitializer.cs Line59

Jul 18, 2012 at 6:18 PM

RepositoryInitializer.cs

Line59 : this.Context.Set<Country>().ToList().Count();

System.ArgumentException was unhandled by user code

Message=Unable to find the requested .Net Framework Data Provider.  It may not be installed.

 

How can I handle this problem...?

Developer
Jul 19, 2012 at 1:32 PM

Hi,

I believe this problem could be related to the Silk Installation System requirements, particularly you could check that you have Microsoft SQL Server Compact 4.0, and ADO.NET Entity Framework 4.1 - Update 1 installed.

Also, you could review the Readme section to ensure that you have not missed a step from the installation requirements.

Best regards,

Agustin Adami
http://blogs.southworks.net/aadami

Jul 19, 2012 at 3:20 PM

aadami, 

Thanks for your advice.

Microsoft SQL Server Compact 4.0 was not installed.

I installed Microsoft SQL Server Compact 4.0 and Project Silk is working.

Thanks so much!

Best  regards,

monad gon